#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\<\!-* *([A-Za-z]*) *-*\>([\s\S]*?)<!-* *(\b[A-Za-z ]*\b) *-*\>"
Local $sString = "<!-- Text --><b>Text</b>" & @CRLF & _
" <a href="google.com">Link</a>" & @CRLF & _
" <div class="col"><h1>Nested Content</h1><p>More content</p>" & @CRLF & _
" </div>" & @CRLF & _
"<!-- END of Text -->" & @CRLF & _
"More text <!-- Another Tag Comment -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")