import re
regex = re.compile(r"\<\!-* *([A-Za-z]*) *-*\>([\s\S]*?)<!-* *(\b[A-Za-z ]*\b) *-*\>", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<!-- Text --><b>Text</b>\n"
" <a href=\"google.com\">Link</a>\n"
" <div class=\"col\"><h1>Nested Content</h1><p>More content</p>\n"
" </div>\n"
"<!-- END of Text -->\n"
"More text <!-- Another Tag Comment -->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")