using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sx.torrents.php?.page=(.*)";
string input = @"""https://www.empornium.sx/torrents.php?page=45";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}