package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)sx.torrents.php?.page=(.*)`)
var str = `"https://www.empornium.sx/torrents.php?page=45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}