$re = '/sx.torrents.php?.page=(.*)/i';
$str = '"https://www.empornium.sx/torrents.php?page=45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);