#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\p{L}]"
Local $sString = "«Ведёт ли Владимир Путин гибридную войну? В чём его обвиняют? Информационные войны. Кибератаки. В 2007 году из-за кибератак на несколько страшных часов практически прекратило функционировать небольшое прибалтийское государство Эстония. Никаких конкретных доказательств нет. Применение гибридных методов ведения войны по определению невозможно доказать», — говорится в материале телеканала." & @CRLF & _
"" & @CRLF & _
"BBC предупреждает о том, что Россия ведёт гибридную войну. Для желающих взглянуть на ситуацию шире — ответный сюжет от RT:" & @CRLF & _
"" & @CRLF & _
"«Пытается ли Владимир Путин дестабилизировать мир гибридной войной?" & @CRLF & _
"" & @CRLF & _
"Гибридная война — термин, который может применяться для описания любых форм агрессии, кроме прямого вторжения." & @CRLF & _
"" & @CRLF & _
"Критики Путина считают, что таким образом он прокладывает себе дорогу к мировому господству." & @CRLF & _
"" & @CRLF & _
"Так в чём его обвиняют?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")