const regex = /[\p{L}]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{L}]', 'g')
const str = `«Ведёт ли Владимир Путин гибридную войну? В чём его обвиняют? Информационные войны. Кибератаки. В 2007 году из-за кибератак на несколько страшных часов практически прекратило функционировать небольшое прибалтийское государство Эстония. Никаких конкретных доказательств нет. Применение гибридных методов ведения войны по определению невозможно доказать», — говорится в материале телеканала.
BBC предупреждает о том, что Россия ведёт гибридную войну. Для желающих взглянуть на ситуацию шире — ответный сюжет от RT:
«Пытается ли Владимир Путин дестабилизировать мир гибридной войной?
Гибридная война — термин, который может применяться для описания любых форм агрессии, кроме прямого вторжения.
Критики Путина считают, что таким образом он прокладывает себе дорогу к мировому господству.
Так в чём его обвиняют?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}