// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\p{L}]").unwrap();
let string = "«Ведёт ли Владимир Путин гибридную войну? В чём его обвиняют? Информационные войны. Кибератаки. В 2007 году из-за кибератак на несколько страшных часов практически прекратило функционировать небольшое прибалтийское государство Эстония. Никаких конкретных доказательств нет. Применение гибридных методов ведения войны по определению невозможно доказать», — говорится в материале телеканала.
BBC предупреждает о том, что Россия ведёт гибридную войну. Для желающих взглянуть на ситуацию шире — ответный сюжет от RT:
«Пытается ли Владимир Путин дестабилизировать мир гибридной войной?
Гибридная война — термин, который может применяться для описания любых форм агрессии, кроме прямого вторжения.
Критики Путина считают, что таким образом он прокладывает себе дорогу к мировому господству.
Так в чём его обвиняют?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}