# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<!\w)'((?:.|\n)+?'?)'(?!\w))/"\1"/g;t' <<< "'Wow' I'm one of the persons' stackoverflow don't th'em said, 'hey what' I'll handle it.
'Don't do that' he said.
Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India.
'Hey'! you'll, I'm, he's,
some random text
'what if it's
multiline?'
'I'm one of the persons''
'I'm one of the persons''"