import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<!\\w)'((?:.|\\n)+?'?)'(?!\\w))";
final String string = "'Wow' I'm one of the persons' stackoverflow don't th'em said, 'hey what' I'll handle it.\n"
+ "'Don't do that' he said.\n"
+ "Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India.\n"
+ "'Hey'! you'll, I'm, he's, \n"
+ "some random text\n"
+ "'what if it's\n"
+ "multiline?'\n\n"
+ "'I'm one of the persons''\n\n"
+ "'I'm one of the persons''";
final String subst = "\"\\1\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}