$re = '/(?:(?<!\w)\'((?:.|\n)+?\'?)\'(?!\w))/';
$str = '\'Wow\' I\'m one of the persons\' stackoverflow don\'t th\'em said, \'hey what\' I\'ll handle it.
\'Don\'t do that\' he said.
Similar to the \'Kumbh melas\', celebrated by the banks of the holy rivers of India.
\'Hey\'! you\'ll, I\'m, he\'s,
some random text
\'what if it\'s
multiline?\'
\'I\'m one of the persons\'\'
\'I\'m one of the persons\'\'';
$subst = "\"\1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;