using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[{(?:(?!\]\])[\s\S])*""fid"":""\K\d+";
string input = @"[[{""fid"":""28"",""view_mode"":""teaser"",""fields"":{},""type"":""media"",""attributes"":{""class"":""media-element file-teaser""},""link_text"":null}]]
Second Paragraph
[[{""fid"":""26"",""view_mode"":""preview"",""fields"":{},""type"":""media"",""attributes"":{""class"":""file media-element file-preview""},""link_text"":""mohan sample.mp4""}]]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}