const regex = /\[\[{(?:(?!\]\])[\s\S])*"fid":"\K\d+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[{(?:(?!\\]\\])[\\s\\S])*"fid":"\\K\\d+', 'gmi')
const str = `[[{"fid":"28","view_mode":"teaser","fields":{},"type":"media","attributes":{"class":"media-element file-teaser"},"link_text":null}]]
Second Paragraph
[[{"fid":"26","view_mode":"preview","fields":{},"type":"media","attributes":{"class":"file media-element file-preview"},"link_text":"mohan sample.mp4"}]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}