$re = '/\[\[{(?:(?!\]\])[\s\S])*"fid":"\K\d+/mi';
$str = '[[{"fid":"28","view_mode":"teaser","fields":{},"type":"media","attributes":{"class":"media-element file-teaser"},"link_text":null}]]
Second Paragraph
[[{"fid":"26","view_mode":"preview","fields":{},"type":"media","attributes":{"class":"file media-element file-preview"},"link_text":"mohan sample.mp4"}]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);