const regex = /'(?![^']*dark)[^']*'/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'(?![^\']*dark)[^\']*\'', 'gmi')
const str = `Only 'together' can we turn him to the 'dark side' of the Force`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);