import re
regex = re.compile(r"'(?![^']*dark)[^']*'", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Only 'together' can we turn him to the 'dark side' of the Force"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)