$re = '/\'(?![^\']*dark)[^\']*\'/mi';
$str = 'Only \'together\' can we turn him to the \'dark side\' of the Force';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;