re = /('[^']*\bdark\b[^']*')|'[^']*'/mi
str = 'Only \'together\' can we turn him to the \'dark side\' of the Force'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result