// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)('[^']*\bdark\b[^']*')|'[^']*'").unwrap();
let string = "Only 'together' can we turn him to the 'dark side' of the Force";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}