package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:def)\s+([^\s]+)`)
var str = `def name1
toSomething
def name2
toSomethingElse`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}