re = /(?:def)\s+([^\s]+)/
str = 'def name1
toSomething
def name2
toSomethingElse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end