$re = '/(?:def)\s+([^\s]+)/';
$str = 'def name1
toSomething
def name2
toSomethingElse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);