import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^\\)]+\\)(?![^\\[]*\\])";
final String string = "(hello world) [oh (hello) there, (how) are you?] (hey!!) [(Uh, can you hear me?)] (Yep, [fine]) [be sure (to be) coming (tonight) for the (party)]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}