$re = '/\([^\)]+\)(?![^\[]*\])/';
$str = '(hello world) [oh (hello) there, (how) are you?] (hey!!) [(Uh, can you hear me?)] (Yep, [fine]) [be sure (to be) coming (tonight) for the (party)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);