re = /\([^\)]+\)(?![^\[]*\])/
str = '(hello world) [oh (hello) there, (how) are you?] (hey!!) [(Uh, can you hear me?)] (Yep, [fine]) [be sure (to be) coming (tonight) for the (party)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end