package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[^_]*(?:_)?){5})_(.*)`)
var str = `ks_hdfkshdkfhsdkfhskdhfkshdfksdhfskdhfksdhfskhdfkshkfhksdhfksdhfkshdkfhsdkfhskdhfksdfkdssfdsdfsfd
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}