$re = '/((?:[^_]*(?:_)?){5})_(.*)/';
$str = 'ks_hdfkshdkfhsdkfhskdhfkshdfksdhfskdhfksdhfskhdfkshkfhksdhfksdhfkshdkfhsdkfhskdhfksdfkdssfdsdfsfd
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);