package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^dados/series/[a-z0-9A-Z\-]+/?$`)
var str = `dados/series/ola-mundo
dados/series/ola-mundo/
dados/series/ola-mundo/configs
dados/series/ola-mundo/configs/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}