import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^dados/series/[a-z0-9A-Z\\-]+/?$";
final String string = "dados/series/ola-mundo\n\n"
+ "dados/series/ola-mundo/\n\n"
+ "dados/series/ola-mundo/configs\n\n"
+ "dados/series/ola-mundo/configs/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}