re = /^dados\/series\/[a-z0-9A-Z\-]+\/?$/m
str = 'dados/series/ola-mundo
dados/series/ola-mundo/
dados/series/ola-mundo/configs
dados/series/ola-mundo/configs/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end