#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:[\?&](foo\=[^&]*))|(?:[\?&](foo(?=[&#])))|(?:&(foo(?!.)))"
Local $sString = "foo?foo=bar&testfoo=2&foo&foo"
Local $sSubst = "match"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)