re = /(?:[\?&](foo\=[^&]*))|(?:[\?&](foo(?=[&#])))|(?:&(foo(?!.)))/i
str = 'foo?foo=bar&testfoo=2&foo&foo'
subst = 'match'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result