using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\?&](foo\=[^&]*))|(?:[\?&](foo(?=[&#])))|(?:&(foo(?!.)))";
string substitution = @"match";
string input = @"foo?foo=bar&testfoo=2&foo&foo";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}