# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|\n)(\nsecond thing:\s*[^\n]+\n)|(first thing:\s*[^\n]+\n(?!second thing:))|(second thing:\s*[^\n]+\n(?!third thing:))|(third thing:\s*[^\n]+\n\n)/\3third thing: NA\n/gs;t' <<< "first thing: content 1
second thing: content 2
fourth thing: content 4
"