import Foundation
let pattern = #"(?:^|\n)(\nsecond thing:\s*[^\n]+\n)|(first thing:\s*[^\n]+\n(?!second thing:))|(second thing:\s*[^\n]+\n(?!third thing:))|(third thing:\s*[^\n]+\n\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
first thing: content 1
second thing: content 2
fourth thing: content 4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3third thing: NA\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)