$re = '/(?:^|\n)(\nsecond thing:\s*[^\n]+\n)|(first thing:\s*[^\n]+\n(?!second thing:))|(second thing:\s*[^\n]+\n(?!third thing:))|(third thing:\s*[^\n]+\n\n)/s';
$str = 'first thing: content 1
second thing: content 2
fourth thing: content 4
';
$subst = "\3third thing: NA\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;