# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\/(forum\/|cms\/|wcf\/|calendar\/|filebase\/|blog\/|gallery\/)?([^.\n]+)$/\/${1}index.php?${2}/gm;t' <<< "/article/7-where-to-find-the-new-pve-elite-skills/
/forum/
/forum/thread/1409-lgit-legit-guild-lgit/?pageNo=6
/forum/thread/2956-chat-filter-filter-out-gold-spammers/
/forum/thread/1607-minions-of-the-rabbit-legion-pupu/
/forum/thread/1607-minions-of-the-rabbit-legion-pupu/?action=firstNew
/forum/?action=firstNew "