# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^/(forum/|cms/|wcf/|calendar/|filebase/|blog/|gallery/)?([^.\n]+)$"
test_str = ("/article/7-where-to-find-the-new-pve-elite-skills/\n"
"/forum/\n"
"/forum/thread/1409-lgit-legit-guild-lgit/?pageNo=6\n"
"/forum/thread/2956-chat-filter-filter-out-gold-spammers/\n"
"/forum/thread/1607-minions-of-the-rabbit-legion-pupu/\n"
"/forum/thread/1607-minions-of-the-rabbit-legion-pupu/?action=firstNew\n"
"/forum/?action=firstNew ")
subst = "/${1}index.php?${2}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.