const regex = new RegExp('^/(forum/|cms/|wcf/|calendar/|filebase/|blog/|gallery/)?([^.\\n]+)$', 'gm')
const str = `/article/7-where-to-find-the-new-pve-elite-skills/
/forum/
/forum/thread/1409-lgit-legit-guild-lgit/?pageNo=6
/forum/thread/2956-chat-filter-filter-out-gold-spammers/
/forum/thread/1607-minions-of-the-rabbit-legion-pupu/
/forum/thread/1607-minions-of-the-rabbit-legion-pupu/?action=firstNew
/forum/?action=firstNew `;
const subst = `/${1}index.php?${2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);