using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-']*Моя[-' ]{2,}строка[-']*";
string input = @"-Моя'- ' '-строка--
-Моя'---''-строка--
Моя -строка
Моя--строка
Моя-- строка
Моя-строка
Моя строка";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}