package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-']*Моя[-' ]{2,}строка[-']*`)
var str = `-Моя'- ' '-строка--
-Моя'---''-строка--
Моя -строка
Моя--строка
Моя-- строка
Моя-строка
Моя строка`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}