$re = '/[-\']*Моя[-\' ]{2,}строка[-\']*/u';
$str = '-Моя\'- \' \'-строка--
-Моя\'---\'\'-строка--
Моя -строка
Моя--строка
Моя-- строка
Моя-строка
Моя строка';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);