using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"output.*?\K\d[\d.]*";
string input = @"Approxmiate output size of output: 2.268 kilobytes
some entirely different string: 2.268 kilobytes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}