const regex = /output.*?\K\d[\d.]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('output.*?\\K\\d[\\d.]*', 'gm')
const str = `Approxmiate output size of output: 2.268 kilobytes
some entirely different string: 2.268 kilobytes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}