using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d\d([-./ ]?)\d{3}\1\d{4}$";
string input = @"55.635.8828
72/683/1582
86 942 7682
581827998
56.855/9856
56 4559428
52-355/9984";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}