#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(tag*)>(.*?)<\/\1>\."
Local $sString = "<p><tag>Lorem</tag>. Excepteur sint.</p>" & @CRLF & _
"<p><tag>Lorem.</tag> Excepteur sint.</p>" & @CRLF & _
"" & @CRLF & _
"<p><tag>Lorem ipsum</tag>. Excepteur sint.</p>" & @CRLF & _
"<p><tag>Lorem ipsum.</tag> Excepteur sint.</p>" & @CRLF & _
"" & @CRLF & _
"<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>" & @CRLF & _
"<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")