re = /<(tag*)>(.*?)<\/\1>\./
str = '<p><tag>Lorem</tag>. Excepteur sint.</p>
<p><tag>Lorem.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum</tag>. Excepteur sint.</p>
<p><tag>Lorem ipsum.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end