using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(tag*)>(.*?)<\/\1>\.";
string input = @"<p><tag>Lorem</tag>. Excepteur sint.</p>
<p><tag>Lorem.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum</tag>. Excepteur sint.</p>
<p><tag>Lorem ipsum.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}