package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s*(صح)\s*`)
var str = `
تستخدم أجهزة مشغلات الصوت إم بي 3 MP3 Player كبديل لمعامل اللغة. صح 73`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}