re = /\s*(صح)\s*/i
str = '
تستخدم أجهزة مشغلات الصوت إم بي 3 MP3 Player كبديل لمعامل اللغة. صح 73'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end